aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2009-09-03 19:29:54 -0300
committerHugo Lima <hugo.lima@openbossa.org>2009-09-03 19:29:54 -0300
commit74ad15b93b2c3816850acb702c669be8ce0fc4ab (patch)
treef98962c959afdbb7b0b6b02abc38098b62886bf6 /CMakeLists.txt
parent518028765c892b7a6a840cca92376ccc8b77b04c (diff)
- Merged boostpythongeneratorversion.h.in and generator_plugin_dir.h.in
into generatorrunnerconfig.h - Added some variables to FindGeneratorRunner.cmake * GENERATORRUNNER_PLUGIN_DIR The dir where the generator plugins should be installed. * GENERATORRUNNER_VERSION The generatorrunner current version.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 828798062..fdf3c5850 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,11 +19,7 @@ set(generator_plugin_DIR ${LIB_INSTALL_DIR}/generatorrunner)
add_definitions(${QT_DEFINITIONS})
-set(boostpythongenerator_VERSION ${generator_VERSION})
-configure_file(boostpythongeneratorversion.h.in ${CMAKE_CURRENT_BINARY_DIR}/boostpythongeneratorversion.h @ONLY)
-
-# TODO Install it.
-configure_file(generator_plugin_dir.h.in ${CMAKE_CURRENT_BINARY_DIR}/generator_plugin_dir.h @ONLY)
+configure_file(generatorrunnerconfig.h.in ${CMAKE_CURRENT_BINARY_DIR}/generatorrunnerconfig.h @ONLY)
set(CMAKE_BUILD_TYPE Debug)
@@ -59,7 +55,7 @@ add_custom_target(uninstall "${CMAKE_COMMAND}"
-set(ARCHIVE_NAME ${CMAKE_PROJECT_NAME}-${boostpythongenerator_VERSION})
+set(ARCHIVE_NAME ${CMAKE_PROJECT_NAME}-${generator_VERSION})
add_custom_target(dist
COMMAND git archive --prefix=${ARCHIVE_NAME}/ HEAD
| bzip2 > ${CMAKE_BINARY_DIR}/${ARCHIVE_NAME}.tar.bz2