aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2009-11-24 13:15:16 -0300
committerMarcelo Lira <marcelo.lira@openbossa.org>2009-11-24 15:35:19 -0300
commit81282d09cd9b03bade993957a9fc2791eda3393e (patch)
tree08c817cb0d9d9872ac34b77c1b6bcd2247262ada /CMakeLists.txt
parente00d987174d56826d9a5fb9ba9983409ad71c375 (diff)
Added an option to generate code without using the "#define protected public"
hack, that doesn't work on the MS Windows platform. When generating the bindings it adds public dispatchers for protected methods on C++ classes that have them. When avoiding the hack classes that have protected methods get C++ wrappers instead of just the ones with virtual methods. On top of this, support for virtual (and protected) destructors have improved.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 95673330b..1d9682c00 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,9 @@ else (MSVC)
set(CMAKE_CXX_FLAGS_RELEASE "-Wall -DNDEBUG -O2 -Wl,-O1 -Wl,--hash-style=gnu -fvisibility=hidden")
set(CMAKE_CXX_FLAGS_DEBUG "-g -Wall -fvisibility=hidden")
endif (MSVC)
+if (WIN32)
+add_definitions("-DAVOID_PROTECTED_HACK")
+endif(WIN32)
set(LIB_SUFFIX "" CACHE STRING "Define suffix of directory name (32/64)" )
set(LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}" CACHE PATH "The subdirectory relative to the install prefix where libraries will be installed (default is /lib${LIB_SUFFIX})" FORCE)