aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2010-10-25 16:30:40 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:07:23 -0300
commitb13e80c9b7ba4c57f14f509db3b54ed4a3fbfbde (patch)
treedcdeab9e3c4fafc5bd5e0082053e6eaa6f898c8b /CMakeLists.txt
parent8eb8daf1a850759c907e2b2b5ed43fd70af5a665 (diff)
Updated Shiboken cmake files to provide build type information.
The build type information, contained in the the SHIBOKEN_BUILD_TYPE variable, will tell modules linking with libshiboken if it was built in Release or Debug mode. The SHIBOKEN_PYTHON_INTERPRETER variable was also added to the cmake Shiboken files, to make it known which Python interpreter (normal or debug, in systems where this separation exists). SHIBOKEN_PYTHON_LIBRARIES variable tells which Python library libshiboken was linked against.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dab1888bb..dc4c83487 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,7 +26,7 @@ if(MSVC)
set(CMAKE_CXX_FLAGS "/Zc:wchar_t- /GR /EHsc /DWIN32 /D_WINDOWS /D_SCL_SECURE_NO_WARNINGS")
else()
if(CMAKE_HOST_UNIX)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -fvisibility=hidden -Wno-strict-aliasing")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -fvisibility=hidden -Wno-strict-aliasing")
endif()
set(CMAKE_CXX_FLAGS_DEBUG "-g")
option(ENABLE_GCC_OPTIMIZATION "Enable specific GCC flags to optimization library size and performance. Only available on Release Mode" 0)
@@ -69,6 +69,7 @@ execute_process(
OUTPUT_VARIABLE PY_DEBUG
OUTPUT_STRIP_TRAILING_WHITESPACE)
+set(SHIBOKEN_BUILD_TYPE "Release")
if(CMAKE_BUILD_TYPE STREQUAL "Debug")
if(NOT PYTHON_DEBUG_LIBRARIES)
message(FATAL_ERROR "Python debug library not found. Try compile shiboken with -DCMAKE_BUILD_TYPE=Release")
@@ -79,6 +80,7 @@ if(CMAKE_BUILD_TYPE STREQUAL "Debug")
add_definitions("-DPy_DEBUG")
endif()
set(SBK_PYTHON_LIBRARIES ${PYTHON_DEBUG_LIBRARIES})
+ set(SHIBOKEN_BUILD_TYPE "Debug")
else()
set(SBK_PYTHON_LIBRARIES ${PYTHON_LIBRARIES})
add_definitions("-DNDEBUG")