aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Filho <renato.filho@openbossa.org>2010-08-19 17:49:44 -0300
committerRenato Filho <renato.filho@openbossa.org>2010-08-19 18:26:30 -0300
commit0fb81692e3804ff92e326566994c4e1d1255b737 (patch)
tree8c989de6e699ea49171303bffc5e98ee9a31249f /PySide/CMakeLists.txt
parent465649d73e552cfb1e74e343eea3341b2842ccd6 (diff)
Use .pyd for modules on windows.
Reviewer: Luciano Wolf <luciano.wolf@openbossa.org> Hugo Parente Lima <hugo.pl@gmail.com>
Diffstat (limited to 'PySide/CMakeLists.txt')
-rw-r--r--PySide/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/PySide/CMakeLists.txt b/PySide/CMakeLists.txt
index 22ccde833..25f267e16 100644
--- a/PySide/CMakeLists.txt
+++ b/PySide/CMakeLists.txt
@@ -22,6 +22,9 @@ macro(create_pyside_module module_name typesystem_file module_include_dir module
include_directories(${module_name} ${${module_include_dir}})
add_library(${module_name} MODULE ${${module_sources}})
set_target_properties(${module_name} PROPERTIES PREFIX "")
+ if(WIN32)
+ set_target_properties(${module_name} PROPERTIES SUFFIX ".pyd")
+ endif()
target_link_libraries(${module_name} ${${module_libraries}})
if(${module_deps})
add_dependencies(${module_name} ${${module_deps}})