aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Parente Lima <hugo.lima@openbossa.org>2010-05-24 16:30:53 -0300
committerHugo Parente Lima <hugo.lima@openbossa.org>2010-05-24 17:28:48 -0300
commitfbc43d942a6ff0dc5ef2e1446bb96ed6bee7d35c (patch)
tree2aa01a221feb7317e4c634d63b2ec7ed4b404aab /PySide/CMakeLists.txt
parent92a07a7a15394b3f0a01004988d6025e7c8f1e9e (diff)
Initial bindings for QtDeclarative module.
Reviewer: Luciano Wolf <luciano.wolf@openbossa.org> Renato Araújo <renato.filho@openbossa.org>
Diffstat (limited to 'PySide/CMakeLists.txt')
-rw-r--r--PySide/CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/PySide/CMakeLists.txt b/PySide/CMakeLists.txt
index e44c693a1..23e2dc4dc 100644
--- a/PySide/CMakeLists.txt
+++ b/PySide/CMakeLists.txt
@@ -51,7 +51,7 @@ if (NOT QT_QTMULTIMEDIA_FOUND AND ${QTVERSION} VERSION_GREATER 4.5.9)
endif()
endif ()
-# Try to find QtMaemo5 this need be before QtGui for enable some flags on that
+# Try to find QtMaemo5 - it has to be done before QtGui to enable some QtMaemo5 flags
# TODO: Remove this hack when cmake support QtMaemo5 module
if (NOT QT_QTMAEMO5_FOUND AND ${QTVERSION} VERSION_GREATER 4.5.9)
find_path(QT_QTMAEMO5_INCLUDE_DIR QtMaemo5
@@ -65,6 +65,19 @@ if (NOT QT_QTMAEMO5_FOUND AND ${QTVERSION} VERSION_GREATER 4.5.9)
endif()
endif ()
+# Try to find QtDeclarative
+# TODO: Remove this hack when cmake support QtDeclarative module
+if (NOT QT_QTDECLARATIVE_FOUND AND ${QTVERSION} VERSION_GREATER 4.6.0)
+ find_path(QT_QTDECLARATIVE_INCLUDE_DIR QtDeclarative
+ PATHS ${QT_HEADERS_DIR}/QtDeclarative
+ ${QT_LIBRARY_DIR}/QtDeclarative.framework/Headers
+ NO_DEFAULT_PATH)
+ find_library(QT_QTDECLARATIVE_LIBRARY QtDeclarative PATHS ${QT_LIBRARY_DIR} NO_DEFAULT_PATH)
+ if (QT_QTDECLARATIVE_INCLUDE_DIR AND QT_QTDECLARATIVE_LIBRARY)
+ set(QT_QTDECLARATIVE_FOUND ON)
+ endif()
+endif ()
+
HAS_QT_MODULE(QT_QTCORE_FOUND QtCore)
HAS_QT_MODULE(QT_QTGUI_FOUND QtGui)
HAS_QT_MODULE(QT_QTNETWORK_FOUND QtNetwork)
@@ -82,3 +95,4 @@ HAS_QT_MODULE(QT_QTSCRIPT_FOUND QtScript)
HAS_QT_MODULE(QT_QTSCRIPTTOOLS_FOUND QtScriptTools)
HAS_QT_MODULE(QT_QTMULTIMEDIA_FOUND QtMultimedia)
HAS_QT_MODULE(QT_PHONON_FOUND phonon)
+HAS_QT_MODULE(QT_QTDECLARATIVE_FOUND QtDeclarative)