aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/QtGui/CMakeLists.txt
diff options
context:
space:
mode:
authorAnderson Lizardo <anderson.lizardo@openbossa.org>2010-08-13 22:32:07 -0400
committerAnderson Lizardo <anderson.lizardo@openbossa.org>2010-08-26 11:04:58 -0400
commit3c36d444729ee9285bb4ab0252968057bf904a8d (patch)
treebc5790e5afa2bf2cf1589b7f2fd182f471e4bbee /PySide/QtGui/CMakeLists.txt
parent2593f9fccc71a200c5a802b2e05717910885e864 (diff)
Various cleanups to CMakeLists.txt files
* Simplify endmacro(), endif() and else() statements * Remove unused and redundant code * Use AUTO_OS for holding the typesystem suffix (instead of MODULE_NAME) Reviewed-by: Luciano Wolf <luciano.wolf@openbossa.org> Reviewed-by: Hugo Parente Lima <hugo.lima@openbossa.org>
Diffstat (limited to 'PySide/QtGui/CMakeLists.txt')
-rw-r--r--PySide/QtGui/CMakeLists.txt20
1 files changed, 4 insertions, 16 deletions
diff --git a/PySide/QtGui/CMakeLists.txt b/PySide/QtGui/CMakeLists.txt
index 9d2b89704..a848b65e0 100644
--- a/PySide/QtGui/CMakeLists.txt
+++ b/PySide/QtGui/CMakeLists.txt
@@ -31,32 +31,20 @@ macro(CHECK_QT_GUI_MACRO macro_display_name qt_macro module_sources global_sourc
message(STATUS "Testing support to ${macro_display_name} -- disabled")
endif()
endif()
-endmacro(CHECK_QT_GUI_MACRO)
+endmacro()
if(ENABLE_X11)
- set(MODULE_NAME "x11")
set(SPECIFIC_OS_FILES
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtGui/qx11info_wrapper.cpp
)
if(Q_WS_MAEMO_5)
- set(AUTO_OS "MAEMO 5")
- set(MODULE_NAME "maemo")
set(SPECIFIC_OS_FILES
${SPECIFIC_OS_FILES}
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtGui/qabstractkineticscroller_wrapper.cpp
)
- endif(Q_WS_MAEMO_5)
-
-elseif(ENABLE_MAC)
- set(MODULE_NAME "mac")
- set(SPECIFIC_OS_FILES
- )
-elseif(ENABLE_WIN)
- set(MODULE_NAME "win")
- set(SPECIFIC_OS_FILES
- )
-endif(ENABLE_X11)
+ endif()
+endif()
if (${QT_VERSION_MAJOR} EQUAL 4 AND ${QT_VERSION_MINOR} LESS 6)
@@ -98,7 +86,7 @@ else()
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtGui/qvector3d_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtGui/qvector4d_wrapper.cpp
)
-endif (${QT_VERSION_MAJOR} EQUAL 4 AND ${QT_VERSION_MINOR} LESS 6)
+endif ()
set(QtGui_SRC
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtGui/qabstractbutton_wrapper.cpp