aboutsummaryrefslogtreecommitdiffstats
path: root/PySide/QtGui/CMakeLists.txt
diff options
context:
space:
mode:
authorLuciano Wolf <luciano.wolf@openbossa.org>2010-05-24 17:18:09 -0300
committerLuciano Wolf <luciano.wolf@openbossa.org>2010-05-25 15:05:24 -0300
commit893946b5727dfa3489bc3d2fa411fd24fd3d8ff7 (patch)
tree10f47c2e72b3b8fb1d3796d47eeff7baef5fa856 /PySide/QtGui/CMakeLists.txt
parentfbc43d942a6ff0dc5ef2e1446bb96ed6bee7d35c (diff)
Check QT_NO_SESSIONMANAGER flag to avoid generating qsessionmanager_wrapper.
Diffstat (limited to 'PySide/QtGui/CMakeLists.txt')
-rw-r--r--PySide/QtGui/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/PySide/QtGui/CMakeLists.txt b/PySide/QtGui/CMakeLists.txt
index cf9d81ec5..f883e4e60 100644
--- a/PySide/QtGui/CMakeLists.txt
+++ b/PySide/QtGui/CMakeLists.txt
@@ -277,7 +277,6 @@ ${CMAKE_CURRENT_BINARY_DIR}/PySide/QtGui/qresizeevent_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtGui/qrubberband_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtGui/qscrollarea_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtGui/qscrollbar_wrapper.cpp
-${CMAKE_CURRENT_BINARY_DIR}/PySide/QtGui/qsessionmanager_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtGui/qshortcutevent_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtGui/qshortcut_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/PySide/QtGui/qshowevent_wrapper.cpp
@@ -462,6 +461,12 @@ set(QT_SIZEGRIP_SRCS
)
CHECK_QT_GUI_MACRO("SizeGrip Support" QT_NO_SIZEGRIP QT_SIZEGRIP_SRCS QtGui_SRC)
+#Check QT_SESSIONMANAGER support
+set(QT_SESSIONMANAGER_SRCS
+ ${CMAKE_CURRENT_BINARY_DIR}/PySide/QtGui/qsessionmanager_wrapper.cpp
+)
+CHECK_QT_GUI_MACRO("SessionManager Support" QT_NO_SESSIONMANAGER QT_SESSIONMANAGER_SRCS QtGui_SRC)
+
configure_file(typesystem_gui.xml.in
"${CMAKE_CURRENT_BINARY_DIR}/typesystem_gui.xml" @ONLY)