aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2017-11-13 10:14:40 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2017-11-15 15:47:12 +0000
commit522182fc6ef0d06da1d21fd07ab4e440407cca8e (patch)
tree365cc751966b35c13aa82eabce5c44767ea4d0fb /setup.py
parente455d995be989cbdfef2bcd54fd7057a9b036b52 (diff)
Update description of standalone option in setup.py
Mention that it is usable on Linux and macOS, whereas on Windows it is used implicitly. Change-Id: I17f2086e7d4f9ac9ac084bddbcf73644af4bc0d4 Task-number: PYSIDE-558 Reviewed-by: Christian Tismer <tismer@stackless.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d9a245f73..a04ad80c4 100644
--- a/setup.py
+++ b/setup.py
@@ -47,7 +47,9 @@ or
python setup.py install --qmake=</path/to/qt/bin/qmake> [--cmake=</path/to/cmake>] [--openssl=</path/to/openssl/bin>]
to build and install into your current Python installation.
-On Linux you can use option --standalone, to embed Qt libraries to PySide2 distribution
+On Linux and macOS you can use option --standalone, to embed Qt libraries into the PySide2 package.
+The option does not affect Windows, because it is used implicitly, i.e. all relevant DLLs have to
+be copied into the PySide2 package anyway, because there is no proper rpath support on the platform.
You can use option --rpath="your_value" to specify what rpath values should be embedded into the
PySide2 modules and shared libraries. This overrides the automatically generated values when the