aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2016-09-12 13:00:37 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2016-09-12 13:36:48 +0000
commit606f5ebacee8494764ed11aecb006c57027af4e0 (patch)
tree776b217cecfb438541a525250f920cba807dbcfb /setup.py
parentb2853635a95a7109271f961953b00dac83a19950 (diff)
setup.py: Let OPTION_REUSE_BUILD imply OPTION_IGNOREGIT
Change-Id: Id24505e17c39a0e81fab283f04e53923d9f56d6a Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0034e7170..ff7d5d734 100644
--- a/setup.py
+++ b/setup.py
@@ -272,7 +272,7 @@ if OPTION_NOEXAMPLES:
# Initialize, pull and checkout submodules
-if os.path.isdir(".git") and not OPTION_IGNOREGIT and not OPTION_ONLYPACKAGE:
+if os.path.isdir(".git") and not OPTION_IGNOREGIT and not OPTION_ONLYPACKAGE and not OPTION_REUSE_BUILD:
print("Initializing submodules for PySide2 version %s" % __version__)
git_update_cmd = ["git", "submodule", "update", "--init"]
if run_process(git_update_cmd) != 0: