aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCristian Maureira-Fredes <cristian.maureira-fredes@qt.io>2018-05-15 13:23:49 +0200
committerCristian Maureira-Fredes <cristian.maureira-fredes@qt.io>2018-05-15 11:44:48 +0000
commit85dd5623f223ef2279e0660a90da4e78e7072830 (patch)
tree81d488e87efd80255a533ef1a1eaaa1c4ca89b00 /setup.py
parenta1d13bfe47c5b2b7ca2c915dca0094c1f8448deb (diff)
Add option --skip-modules
Allow the user to skip a set of modules when building the module. An example of using this option: --skip-modules=WebEngineCore,WebEngineWidgets,Multimedia Change-Id: I4b7a25acd60d068a886c1e716ddb7b226814b96f Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 5c494eb92..6a0e02706 100644
--- a/setup.py
+++ b/setup.py
@@ -116,6 +116,9 @@ using `setup.py build`:
--module-subset allows for specifying the Qt modules to be built.
A minimal set is: --module-subset=Core,Gui,Test,Widgets
+ --skip-modules allows for specifying the Qt modules that will be
+ skipped during the build process.
+ For example: --skip-modules=WebEngineCore,WebEngineWidgets
--reuse-build option allows recompiling only the modified sources and
not the whole world, shortening development iteration time,
--skip-cmake will reuse the already generated Makefiles (or