aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2018-05-14 16:57:09 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2018-05-16 07:44:00 +0000
commit9d9144b2b44677d2862e389b7a83900ee3e8e44c (patch)
tree9be85f81072a07ec8b94020792fba8da37143930 /setup.py
parent69c19662bbb0de20374116a38ef673f8dc44b053 (diff)
Clarify and fix the path to openssl libs for Coin Windows build
When the --openssl option is given, it should point to the openssl bin directory, and not to the openssl.exe file itself. Clarify this in the setup.py comments, and fix it in coin_build_instructions.py. Task-number: PYSIDE-660 Change-Id: I5b20a8c5a445c9f628c5abc258c43271c490e08c Reviewed-by: Simo Fält <simo.falt@qt.io>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 7 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 6a0e02706..ad6303569 100644
--- a/setup.py
+++ b/setup.py
@@ -56,9 +56,10 @@ and
--cmake=/path/to/bin/cmake
respectively.
-For windows, if OpenSSL support is required, it is necessary to specify
-the directory with:
- --openssl=/path/to/openssl/bin
+For Windows, if OpenSSL support is required, it's necessary to specify
+the directory path that contains the OpenSSL shared libraries
+"libeay32.dll" and "ssleay32.dll", for example:
+ --openssl=C:\OpenSSL-Win64\bin
ADDITIONAL OPTIONS:
@@ -150,8 +151,9 @@ OPTIONAL:
Specifying the --openssl option is only required on Windows.
It is a no-op for other platforms.
- You can specify the location of OpenSSL DLLs with option:
- --openssl=</path/to/openssl/bin>.
+ You can specify the location of the OpenSSL DLLs with the
+ following option:
+ --openssl=</path/to/openssl/bin-directory>.
You can download OpenSSL for Windows here:
http://slproweb.com/products/Win32OpenSSL.html (*)