aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2018-02-23 14:02:57 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2018-02-23 13:09:43 +0000
commited9f21a2ccafdee0e96493b99a249d88d5c4f21a (patch)
tree83bf6febfff76da678379f709c4f059c40ada2eb /setup.py
parent87e85c46052f849ba059eba1979092e66c57faad (diff)
Deprecate --iculib-url option
The option is not being used anymore since commit c605d686f8cc4c8d370ec4d6260fca4b423f5526 , but we need to keep the name around, so that setup.py doesn't error out in Coin because we still pass that option. Change-Id: I6f3433d1feacd8940aa48ba7e1113fe44a19ed9b Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 2 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index abb53517a..8a8970c68 100644
--- a/setup.py
+++ b/setup.py
@@ -294,7 +294,7 @@ OPTION_SKIP_MAKE_INSTALL = has_option("skip-make-install")
OPTION_SKIP_PACKAGING = has_option("skip-packaging")
OPTION_RPATH_VALUES = option_value("rpath")
OPTION_QT_CONF_PREFIX = option_value("qt-conf-prefix")
-OPTION_ICULIB = option_value("iculib-url")
+OPTION_ICULIB = option_value("iculib-url") # Deprecated
OPTION_VERBOSE_BUILD = has_option("verbose-build")
# This is used automatically by distutils.command.install object, to specify final installation
@@ -364,11 +364,7 @@ else:
if OPTION_ICULIB:
if not OPTION_STANDALONE:
- print("--iculib-url is usable only when creating standalone wheel with --standalone switch")
- sys.exit(1)
- if sys.platform != "linux":
- print("--iculib-url is usable only when creating standalone wheels in Linux")
- sys.exit(1)
+ print("--iculib-url option is a no-op option and will be removed soon.")
# Show available versions
if OPTION_LISTVERSIONS: