aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2018-10-30 10:28:08 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2018-10-30 12:24:05 +0000
commitc47e2557e2c7b27258c12cfc1b0cb1aabeebcdc6 (patch)
tree68e529cfc276d21f79444080c61b561524df3a68 /setup.py
parent899b3cfed8e1c3513f8d3001c53b0bb0cc1af548 (diff)
Build scripts: Fix warnings about invalid escape sequences
Fix: setup.py:243: DeprecationWarning: invalid escape sequence \O """ build_scripts\main.py:143: DeprecationWarning: invalid escape sequence \d pattern = "Programming Language :: Python :: (\d+)\.(\d+)" Change-Id: Id9574077d6ad82a5a6852d8c6e02e931f8a079de Reviewed-by: Christian Tismer <tismer@stackless.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 7 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 2c3bf1fec..58bb84b36 100644
--- a/setup.py
+++ b/setup.py
@@ -95,7 +95,7 @@ For Windows, if OpenSSL support is required, it's necessary to specify
the directory path that contains the OpenSSL shared libraries
"libeay32.dll" and "ssleay32.dll", for example:
- --openssl=C:\OpenSSL-Win64\bin
+ --openssl=C:\\OpenSSL-Win64\\bin
This will make sure that the libraries are copied into the PySide2
package and are found by the QtNetwork module.
@@ -122,17 +122,17 @@ e.g.:
* First, we create a bdist_wheel from a full PySide2 build:
- python setup.py bdist_wheel --qmake=c:\Qt\5.12\bin\qmake.exe
- --cmake=c:\tools\cmake\bin\cmake.exe
- --openssl=c:\libs\OpenSSL32bit\bin
+ python setup.py bdist_wheel --qmake=c:\\Qt\\5.12\\bin\\qmake.exe
+ --cmake=c:\\tools\\cmake\\bin\\cmake.exe
+ --openssl=c:\\libs\\OpenSSL32bit\\bin
* Then, we create a bdist_egg reusing the PySide2 build with option
`--only-package`:
python setup.py bdist_egg --only-package
- --qmake=c:\Qt\5.12\bin\qmake.exe
- --cmake=c:\tools\cmake\bin\cmake.exe
- --openssl=c:\libs\OpenSSL32bit\bin
+ --qmake=c:\\Qt\\5.12\\bin\\qmake.exe
+ --cmake=c:\\tools\\cmake\\bin\\cmake.exe
+ --openssl=c:\\libs\\OpenSSL32bit\\bin
You can use the option `--qt-conf-prefix` to pass a path relative to
the PySide2 installed package, which will be embedded into an