aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorrlacko <backup.rlacko@gmail.com>2014-10-29 15:38:34 +0100
committerrlacko <backup.rlacko@gmail.com>2014-10-29 15:38:34 +0100
commit2f63d9bb802bbd5b1b70e94e5bc17ac21e31cfce (patch)
tree97595608c0a025299a7f45c50571f335a32db78e /setup.py
parentdfc92336d94b7f3e779b0ad50c5b72c61cc5f38f (diff)
Fixed invalid path to python scripts folder when installing via setup.py install command
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 1 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 8cced555b..942cf644a 100644
--- a/setup.py
+++ b/setup.py
@@ -243,10 +243,7 @@ class pyside_install(_install):
# for bdist_wininst to use) - in which case we must *not* run our
# installer
if not self.dry_run and not self.root:
- if sys.platform == "win32":
- filename = os.path.join(self.prefix, "Scripts", "pyside_postinstall.py")
- else:
- filename = os.path.join(self.prefix, "bin", "pyside_postinstall.py")
+ filename = os.path.join(self.install_scripts, "pyside_postinstall.py")
if not os.path.isfile(filename):
raise RuntimeError("Can't find '%s'" % (filename,))
print("Executing post install script '%s'..." % filename)