aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRobin Dunn <robin@alldunn.com>2013-06-20 21:58:11 -0700
committerRobin Dunn <robin@alldunn.com>2013-06-20 21:58:11 -0700
commit6e77443df3a6faa0c8c1fef0136a92f26609c72e (patch)
tree4272cbed2752734cb44311d21fed5d7f0aea62aa /setup.py
parentd5d22fe75e9727d0d5aad8186f8cbad6283924af (diff)
Only add OPTION_JOBS to the command line if it's set
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 0ff5dfbb3..ac11e6a77 100644
--- a/setup.py
+++ b/setup.py
@@ -578,7 +578,10 @@ class pyside_build(_build):
raise DistutilsSetupError("Error configuring " + extension)
log.info("Compiling module %s..." % extension)
- if run_process([self.make_path, OPTION_JOBS], log) != 0:
+ cmd_make = [self.make_path]
+ if OPTION_JOBS:
+ cmd_make.append(OPTION_JOBS)
+ if run_process(cmd_make, log) != 0:
raise DistutilsSetupError("Error compiling " + extension)
if extension.lower() == "shiboken":