aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRobin Dunn <rdunn@enthought.com>2013-04-29 13:31:41 -0700
committerRobin Dunn <rdunn@enthought.com>2013-04-29 14:10:13 -0700
commitd5ba61e5d07153626bf4c948b66eb872516c6989 (patch)
tree31b2398d34468cc2e98b40d370f9edd65e3f3945 /setup.py
parent4e5b120cb769496513ed4ee760a6fbc0d38b34d5 (diff)
Add a bogus Extension object so setuptools will know that there are binary extensions and will use the platform and architecture in the egg file name.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 9 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index a78d07a3c..3223b656f 100644
--- a/setup.py
+++ b/setup.py
@@ -70,7 +70,7 @@ from distutils.sysconfig import get_config_var
from distutils.spawn import find_executable
from distutils.command.build import build as _build
-from setuptools import setup
+from setuptools import setup, Extension
from setuptools.command.install import install as _install
from setuptools.command.bdist_egg import bdist_egg as _bdist_egg
@@ -875,4 +875,12 @@ setup(
'bdist_egg': pyside_bdist_egg,
'install': pyside_install,
},
+
+ # Add a bogus extension module (will never be built here since we are
+ # overriding the build command to do it using cmake) so things like
+ # bdist_egg will know that there are extension modules and will name the
+ # dist with the full platform info.
+ ext_modules = [Extension('QtCore', [])],
+ ext_package = 'PySide',
+
)