aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2017-05-23 16:32:38 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2017-05-23 16:33:30 +0200
commit4a4ad11a730a06cef69bea0b5d22d8f2e7337a52 (patch)
tree3d3ca61cf99d0c2103727ccf8f1e4b5a12956619 /setup.py
parentc91492c0108642d10956836887c795a73691defe (diff)
parentffa3cfe0c7eb83b5d318a52d96fbce5434c4bef8 (diff)
Merge remote-tracking branch 'origin/5.6' into 5.9
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 7 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 852b5ea20..d5ff2d756 100644
--- a/setup.py
+++ b/setup.py
@@ -82,24 +82,20 @@ OS X SDK: You can specify which OS X SDK should be used for compilation with the
__version__ = "5.9"
+containedModules = ['shiboken2', 'pyside2']
+
submodules = {
'2.0.0.dev0': [
- ["shiboken2", "dev"],
- ["pyside2", "dev"],
["pyside2-tools", "dev"],
["pyside2-examples", "dev"],
["wiki", "master", ".."],
],
'5.9': [
- ["shiboken2", "5.9"],
- ["pyside2", "5.9"],
["pyside2-tools", "5.9"],
["pyside2-examples", "5.9"],
["wiki", "master", ".."]
],
'5.6': [
- ["shiboken2", "5.6"],
- ["pyside2", "5.6"],
["pyside2-tools", "5.6"],
["pyside2-examples", "5.6"],
["wiki", "master", ".."]
@@ -189,8 +185,10 @@ from utils import osx_localize_libpaths
# guess a close folder name for extensions
def get_extension_folder(ext):
- maybe = list(map(lambda x:x[0], submodules[__version__]))
- folder = difflib.get_close_matches(ext, maybe)[0]
+ candidates = containedModules
+ for gitModules in submodules[__version__]:
+ candidates.append(gitModules[0])
+ folder = difflib.get_close_matches(ext, candidates)[0]
return folder
# make sure that setup.py is run with an allowed python version
@@ -759,7 +757,7 @@ class pyside_build(_build):
if not OPTION_ONLYPACKAGE:
# Build extensions
- for ext in ['shiboken2', 'pyside2', 'pyside2-tools']:
+ for ext in containedModules + ['pyside2-tools']:
self.build_extension(ext)
if OPTION_BUILDTESTS: