aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2017-11-01 17:15:47 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2017-11-03 12:35:09 +0000
commit2bbe2cdb20cc6ee77bb69a0130cd74a161601861 (patch)
tree618e45038b82865c58f5100b272944cda9caf252 /sources/pyside2/CMakeLists.txt
parent13874d8c67a4d4b2cca08fb2f4c96173a6c0c512 (diff)
PySide2: Run shiboken2 with a single Qt module header
Create a per-module header including pyside2_global.h and the module header only instead of passing a global header including all Qt modules. This reduces the amount of code shiboken2 has to parse and minimizes warnings. Change-Id: If3ab8fdf6cabe17b4add65f1e4a0f2e1464ab164 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'sources/pyside2/CMakeLists.txt')
-rw-r--r--sources/pyside2/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/sources/pyside2/CMakeLists.txt b/sources/pyside2/CMakeLists.txt
index d4bb023a0..e880a3e69 100644
--- a/sources/pyside2/CMakeLists.txt
+++ b/sources/pyside2/CMakeLists.txt
@@ -230,9 +230,6 @@ macro(COLLECT_MODULE_IF_FOUND shortname)
if(${_name_found})
message(STATUS "module ${name} found (${ARGN})")
- # Put the module at the end of pyside2_global.h
- file(APPEND "${CMAKE_CURRENT_BINARY_DIR}/PySide2/pyside2_global.h.add"
- "#include \"Qt${shortname}/Qt${shortname}\"\n")
# record the shortnames for the tests
list(APPEND all_module_shortnames ${shortname})
else()