aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Maureira-Fredes <cristian.maureira-fredes@qt.io>2018-05-15 13:23:49 +0200
committerCristian Maureira-Fredes <cristian.maureira-fredes@qt.io>2018-05-15 11:44:48 +0000
commit85dd5623f223ef2279e0660a90da4e78e7072830 (patch)
tree81d488e87efd80255a533ef1a1eaaa1c4ca89b00 /sources/pyside2/CMakeLists.txt
parenta1d13bfe47c5b2b7ca2c915dca0094c1f8448deb (diff)
Add option --skip-modules
Allow the user to skip a set of modules when building the module. An example of using this option: --skip-modules=WebEngineCore,WebEngineWidgets,Multimedia Change-Id: I4b7a25acd60d068a886c1e716ddb7b226814b96f Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'sources/pyside2/CMakeLists.txt')
-rw-r--r--sources/pyside2/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/sources/pyside2/CMakeLists.txt b/sources/pyside2/CMakeLists.txt
index 151d37f8b..e1ef529aa 100644
--- a/sources/pyside2/CMakeLists.txt
+++ b/sources/pyside2/CMakeLists.txt
@@ -353,6 +353,14 @@ if (NOT MODULES)
set(MODULES "${ALL_ESSENTIAL_MODULES};${ALL_OPTIONAL_MODULES}")
endif()
+# Removing from the MODULES list the items that were defined with
+# -DSKIP_MODULES on command line
+if (SKIP_MODULES)
+ foreach(s ${SKIP_MODULES})
+ list(REMOVE_ITEM MODULES ${s})
+ endforeach()
+endif()
+
foreach(m ${MODULES})
COLLECT_MODULE_IF_FOUND(${m})
endforeach()