aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/PySide2/QtQuick/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2017-11-02 14:18:03 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2017-11-06 07:56:25 +0000
commitf2063ee4737f90c5d412a9a328672fde32b033eb (patch)
treebe06749b135fd45a9ca5b0e1d213ef743883dcf5 /sources/pyside2/PySide2/QtQuick/CMakeLists.txt
parent0de4dffa0c5abc80df7063daf6bc9d1754891a9d (diff)
PySide2: Simplify typesystem path handling
Modify the typesystem.xml files such that all dependent files are loaded via module (for example, QtCore/typesystem_core.xml). As a result, it is no longer necessary to add each dependent directory to the typesystem path; it is sufficient to pass the binary and source path of PySide2 and the source directory of the Qt module only. This requires rewriting the dependency checking for --reuse-build so that it loops over the source directories of the dependent Qt modules. Change-Id: Ib234c2673f4ee93cc8a3282fac69bcfcfaebd0ac Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'sources/pyside2/PySide2/QtQuick/CMakeLists.txt')
-rw-r--r--sources/pyside2/PySide2/QtQuick/CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/sources/pyside2/PySide2/QtQuick/CMakeLists.txt b/sources/pyside2/PySide2/QtQuick/CMakeLists.txt
index 491fc9d9e..01e369e7a 100644
--- a/sources/pyside2/PySide2/QtQuick/CMakeLists.txt
+++ b/sources/pyside2/PySide2/QtQuick/CMakeLists.txt
@@ -58,13 +58,6 @@ if (Qt5Quick_VERSION VERSION_GREATER 5.5.1)
)
endif()
-
-make_path(QtQuick_typesystem_path ${QtCore_SOURCE_DIR} ${QtCore_BINARY_DIR}
- ${QtGui_SOURCE_DIR} ${QtGui_BINARY_DIR}
- ${QtNetwork_SOURCE_DIR} ${QtNetwork_BINARY_DIR}
- ${QtQml_SOURCE_DIR} ${QtQml_BINARY_DIR}
- ${QtQuick_SOURCE_DIR})
-
set(QtQuick_include_dirs ${QtQuick_SOURCE_DIR}
${QtQml_SOURCE_DIR}
${Qt5Core_INCLUDE_DIRS}
@@ -95,6 +88,6 @@ create_pyside_module(QtQuick
QtQuick_include_dirs
QtQuick_libraries
QtQuick_deps
- QtQuick_typesystem_path
+ QtQuick_SOURCE_DIR
QtQuick_SRC
QtQuick_registerType)