aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/tests/pysidetest/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2017-06-23 14:36:03 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2017-06-23 14:36:07 +0200
commitcdf8c68066e79e25c17eb725e4a471b0b83df544 (patch)
tree9a8ddcad64190d88102d73e8a62f9c201209a4f6 /sources/pyside2/tests/pysidetest/CMakeLists.txt
parent09b06dd125323609af50de3afbfd5a4352521543 (diff)
parenteefadcef3733bfcf370f67d844dd890fdaeb17a4 (diff)
Merge remote-tracking branch 'origin/5.6' into 5.9
Diffstat (limited to 'sources/pyside2/tests/pysidetest/CMakeLists.txt')
-rw-r--r--sources/pyside2/tests/pysidetest/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/sources/pyside2/tests/pysidetest/CMakeLists.txt b/sources/pyside2/tests/pysidetest/CMakeLists.txt
index 73644a057..bca2f5387 100644
--- a/sources/pyside2/tests/pysidetest/CMakeLists.txt
+++ b/sources/pyside2/tests/pysidetest/CMakeLists.txt
@@ -3,6 +3,9 @@ project(testbinding)
cmake_minimum_required(VERSION 2.6)
+# On Windows, don't link to qtmain.lib for executables automatically.
+cmake_policy(SET CMP0020 OLD)
+
set(QT_USE_QTCORE 1)
# no more supported: include(${QT_USE_FILE})
add_definitions(${Qt5Core_DEFINITIONS})
@@ -117,7 +120,7 @@ target_link_libraries(testbinding
${Qt5Widgets_LIBRARIES}
${SBK_PYTHON_LIBRARIES})
-add_dependencies(testbinding pyside2 QtCore QtGui QtWidgets libpyside pysidetest)
+add_dependencies(testbinding pyside2 QtCore QtGui QtWidgets pysidetest)
PYSIDE_TEST(decoratedslot_test.py)
PYSIDE_TEST(delegatecreateseditor_test.py)