aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/tests/pysidetest/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2017-11-02 14:18:03 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2017-11-06 07:56:25 +0000
commitf2063ee4737f90c5d412a9a328672fde32b033eb (patch)
treebe06749b135fd45a9ca5b0e1d213ef743883dcf5 /sources/pyside2/tests/pysidetest/CMakeLists.txt
parent0de4dffa0c5abc80df7063daf6bc9d1754891a9d (diff)
PySide2: Simplify typesystem path handling
Modify the typesystem.xml files such that all dependent files are loaded via module (for example, QtCore/typesystem_core.xml). As a result, it is no longer necessary to add each dependent directory to the typesystem path; it is sufficient to pass the binary and source path of PySide2 and the source directory of the Qt module only. This requires rewriting the dependency checking for --reuse-build so that it loops over the source directories of the dependent Qt modules. Change-Id: Ib234c2673f4ee93cc8a3282fac69bcfcfaebd0ac Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'sources/pyside2/tests/pysidetest/CMakeLists.txt')
-rw-r--r--sources/pyside2/tests/pysidetest/CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/sources/pyside2/tests/pysidetest/CMakeLists.txt b/sources/pyside2/tests/pysidetest/CMakeLists.txt
index 16380e490..0a367e8a5 100644
--- a/sources/pyside2/tests/pysidetest/CMakeLists.txt
+++ b/sources/pyside2/tests/pysidetest/CMakeLists.txt
@@ -66,11 +66,8 @@ make_path(testbinding_include_dirs ${pyside2_BINARY_DIR}
${Qt5Widgets_DIRECT_INCLUDE_DIR}
)
-make_path(testbinding_typesystem_path ${CMAKE_CURRENT_SOURCE_DIR}
- ${pyside2_SOURCE_DIR}
- ${QtCore_SOURCE_DIR} ${QtGui_SOURCE_DIR} ${QtWidgets_SOURCE_DIR}
- ${QtCore_BINARY_DIR} ${QtGui_BINARY_DIR} ${QtWidgets_BINARY_DIR}
- )
+make_path(testbinding_typesystem_path ${pyside2_SOURCE_DIR}
+ ${pyside2_BINARY_DIR})
add_custom_command(OUTPUT ${testbinding_SRC}
COMMAND ${SHIBOKEN_BINARY} ${GENERATOR_EXTRA_FLAGS}