aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorrenatofilho <renato.filho@openbossa.org>2010-09-21 13:45:46 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:07:18 -0300
commit24d496c1d05baae8f129d76207709276391faebf (patch)
tree2a72f5a6ecbc15d6cd89aff385927b407c309b93 /tests/CMakeLists.txt
parentf2bd66ead497ba2c17f2124ed7e1487251aca6d0 (diff)
Move Python debug check to root Cmake file.
Reviewer: Hugo Parente Lima <hugo.pl@gmail.com> Luciano Wolf <luciano.wolf@openbossa.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt21
1 files changed, 0 insertions, 21 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 48d9de484..e33305dff 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,27 +1,6 @@
add_subdirectory(libsample)
add_subdirectory(libother)
-# Detect if the python libs were compiled in debug mode
-execute_process(
- COMMAND ${PYTHON_EXECUTABLE} -c "from distutils import sysconfig; \\
- print sysconfig.get_config_var('Py_DEBUG')"
- OUTPUT_VARIABLE PY_DEBUG
- OUTPUT_STRIP_TRAILING_WHITESPACE)
-
-if(CMAKE_BUILD_TYPE STREQUAL "Debug")
- if(NOT PYTHON_DEBUG_LIBRARIES)
- message(FATAL_ERROR "Python debug library not found. Try compile shiboken with -DCMAKE_BUILD_TYPE=Release")
- endif()
- if(NOT PY_DEBUG)
- message(WARNING "Compiling shiboken with debug enabled, but the python executable was not compiled with debug support.")
- else()
- add_definitions("-DPy_DEBUG")
- endif()
- set(SBK_PYTHON_LIBRARIES ${PYTHON_DEBUG_LIBRARIES})
-else()
- set(SBK_PYTHON_LIBRARIES ${PYTHON_LIBRARIES})
- add_definitions("-DNDEBUG")
-endif()
add_subdirectory(samplebinding)
add_subdirectory(otherbinding)