aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2010-01-14 14:40:36 -0200
committerHugo Lima <hugo.lima@openbossa.org>2010-01-14 14:40:36 -0200
commitc40f61ff076928f07591070763069cc75918768e (patch)
treefa65e78cae793615924a36a1123b577f2033659c /tests/CMakeLists.txt
parent4ec281e299faadeb20dac4a7cf55f16c9124ebeb (diff)
Removed type discovery tests from blacklist and added "other" binding directory to the PYTHONPATH.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 7b08e674e..98068f018 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -5,7 +5,7 @@ add_subdirectory(otherbinding)
file(GLOB TEST_FILES samplebinding/*_test.py otherbinding/*_test.py)
-set(test_blacklist derived otherderived)
+set(test_blacklist "")
foreach(test_file ${TEST_FILES})
string(REGEX MATCH "/([^/]+)_test.py" test_name ${test_file})
@@ -13,7 +13,7 @@ foreach(test_file ${TEST_FILES})
add_test("${CMAKE_MATCH_1}" sh
"${CMAKE_CURRENT_SOURCE_DIR}/run_test.sh"
"${libsample_BINARY_DIR}:${libshiboken_BINARY_DIR}"
- "${sample_BINARY_DIR}"
+ "${sample_BINARY_DIR}:${other_BINARY_DIR}"
"${PYTHON_EXECUTABLE}"
"${test_file}")
set_tests_properties(${CMAKE_MATCH_1} PROPERTIES TIMEOUT 5)