aboutsummaryrefslogtreecommitdiffstats
path: root/doc/compiling/setup-apiextractor.rst
diff options
context:
space:
mode:
Diffstat (limited to 'doc/compiling/setup-apiextractor.rst')
-rw-r--r--doc/compiling/setup-apiextractor.rst46
1 files changed, 0 insertions, 46 deletions
diff --git a/doc/compiling/setup-apiextractor.rst b/doc/compiling/setup-apiextractor.rst
deleted file mode 100644
index ea6fb9d9..00000000
--- a/doc/compiling/setup-apiextractor.rst
+++ /dev/null
@@ -1,46 +0,0 @@
-
-.. _api-extractor:
-
-**************
-API Extractor
-**************
-
-Overview
-========
-
-The **API Extractor** library is used by the binding generator to
-parse the header and typesystem files to create an internal
-representation of the API. It is based on the QtScriptGenerator
-codebase.
-
-Getting the sources
-===================
-
-* Download URL: http://www.pyside.org/downloads/
-
-Build requirements
-==================
-
-* Qt4.5 development headers and libraries >= 4.5.0
-* cmake >= 2.6.0
-
-Building and installing
-=======================
-
-To build and install just follow the generic cmake instructions in section
-:ref:`cmake-primer`.
-
-Debian packaging
-================
-
-In order to compile this package in a debian environment, make sure the
-following packages are installed:
-
-* debhelper (>= 5)
-* cdbs
-* cmake (>= 2.6.0)
-* libqt4-dev (>= 4.5)
-
-And then you can build the package using::
-
- $ dpkg-buildpackage -rfakeroot