aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 9 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 813d7c013..a24e656e5 100644
--- a/setup.py
+++ b/setup.py
@@ -60,6 +60,8 @@ For Windows, if OpenSSL support is required, it's necessary to specify
the directory path that contains the OpenSSL shared libraries
"libeay32.dll" and "ssleay32.dll", for example:
--openssl=C:\OpenSSL-Win64\bin
+This will make sure that the libraries are copied into the PySide2
+package and are found by the QtNetwork module.
ADDITIONAL OPTIONS:
@@ -150,9 +152,14 @@ REQUIREMENTS:
OPTIONAL:
* OpenSSL:
- Specifying the --openssl option is only required on Windows.
+ Specifying the --openssl option only affects Windows.
It is a no-op for other platforms.
+ Please note that official Windows packages do not ship the
+ OpenSSL libraries due to import / export restrictions as
+ described in
+ http://doc.qt.io/qt-5/ssl.html#import-and-export-restrictions
+
You can specify the location of the OpenSSL DLLs with the
following option:
--openssl=</path/to/openssl/bin-directory>.
@@ -177,7 +184,7 @@ OPTIONAL:
shared libraries, are not currently compatible with
standalone PySide2 packages.
- (*) Revised on 23.03.2018
+ (*) Revised on 21.06.2018
* macOS SDK:
You can specify which macOS SDK should be used for compilation with