aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken2/tests/libsmart/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sources/shiboken2/tests/libsmart/CMakeLists.txt')
-rw-r--r--sources/shiboken2/tests/libsmart/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/sources/shiboken2/tests/libsmart/CMakeLists.txt b/sources/shiboken2/tests/libsmart/CMakeLists.txt
new file mode 100644
index 000000000..66c27cdae
--- /dev/null
+++ b/sources/shiboken2/tests/libsmart/CMakeLists.txt
@@ -0,0 +1,11 @@
+project(libsmart)
+
+set(libsmart_SRC
+smart.cpp
+)
+
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+add_definitions("-DLIBSMART_BUILD")
+add_library(libsmart SHARED ${libsmart_SRC})
+set_property(TARGET libsmart PROPERTY PREFIX "")
+