aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 000000000..c1569517e
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,20 @@
+add_subdirectory(libsample)
+add_subdirectory(samplebinding)
+
+file(GLOB TEST_FILES samplebinding/*_test.py)
+
+foreach(test_file ${TEST_FILES})
+ string(REGEX MATCH "/([^/]+)_test.py" test_name ${test_file})
+ add_test(${CMAKE_MATCH_1} sh
+ ${CMAKE_CURRENT_SOURCE_DIR}/run_test.sh
+ "${libsample_BINARY_DIR}:${libshiboken_BINARY_DIR}"
+ "${sample_BINARY_DIR}"
+ ${PYTHON_EXECUTABLE}
+ ${test_file})
+ set_tests_properties(${CMAKE_MATCH_1} PROPERTIES TIMEOUT 5)
+
+# Should set python path here
+# Looks like it's fixed in 2.8:
+# http://www.vtk.org/Bug/print_bug_page.php?bug_id=7885
+endforeach(test_file ${TEST_FILES})
+