summaryrefslogtreecommitdiffstats
path: root/startupscreen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'startupscreen/CMakeLists.txt')
-rw-r--r--startupscreen/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/startupscreen/CMakeLists.txt b/startupscreen/CMakeLists.txt
new file mode 100644
index 0000000..3b9bdf9
--- /dev/null
+++ b/startupscreen/CMakeLists.txt
@@ -0,0 +1,29 @@
+cmake_minimum_required(VERSION 3.14)
+
+project(startupscreen LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOUIC ON)
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+
+set(CMAKE_CXX_STANDARD 11)
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
+
+find_package(QT NAMES Qt6 Qt5 COMPONENTS Core Quick REQUIRED)
+find_package(Qt${QT_VERSION_MAJOR} COMPONENTS Core Quick REQUIRED)
+
+add_executable(startupscreen
+ main.cpp
+ qml.qrc
+)
+
+target_compile_definitions(startupscreen
+ PRIVATE $<$<OR:$<CONFIG:Debug>,$<CONFIG:RelWithDebInfo>>:QT_QML_DEBUG>)
+target_link_libraries(startupscreen
+ PRIVATE Qt${QT_VERSION_MAJOR}::Core Qt${QT_VERSION_MAJOR}::Quick)
+
+install(TARGETS startupscreen
+ DESTINATION "/usr/bin"
+)