summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mjw@redhat.com>2015-05-21 23:36:51 +0200
committerMark Wielaard <mjw@redhat.com>2015-05-27 15:09:36 +0200
commit2b250b759799eaa43bce1643b7072be8c5c19c01 (patch)
tree9adec3f0c274efbf2c759fd8caa9d9a48a1c4de4 /Makefile.am
parentc2297eab17b7dbb98021b51f063f71d1cdc7893a (diff)
configure: Add --enable-sanitize-undefined.
Now that we are -fsanitize=undefined clean make sure we keep it that way. We do have to disable alignment checking. Because we might explicitly use unaligned accesses (see ALLOW_UNALIGNED). Rename DISTCHECK_CONFIGURE_FLAGS to AM_DISTCHECK_CONFIGURE_FLAGS, so the user can override. And add --enable-sanitize-undefined. Signed-off-by: Mark Wielaard <mjw@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d044a7cb..1454d043 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,9 +33,9 @@ EXTRA_DIST = elfutils.spec GPG-KEY NOTES CONTRIBUTING \
# Make sure the test build uses the same compiler, which on e.g. ppc64
# determines which platform we are actually testing.
# Run all tests under valgrind.
-DISTCHECK_CONFIGURE_FLAGS = \
+AM_DISTCHECK_CONFIGURE_FLAGS = \
--libdir=`echo $(libdir) | sed "s,^$(exec_prefix),$$dc_install_base,"`\
- --enable-valgrind \
+ --enable-valgrind --enable-sanitize-undefined \
CC="$(CC)"
distcheck-hook: