summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRoland McGrath <roland@redhat.com>2005-11-18 23:55:47 +0000
committerRoland McGrath <roland@redhat.com>2005-11-18 23:55:47 +0000
commit9365d2c3439c524c9ca0b9d70f0a559d392a7e05 (patch)
treea497fe123eb3b18e4af66b94641b47ae26026962 /Makefile.am
parent32240f3d2bfd813354c63668dc966c8e27eaec40 (diff)
2005-11-18 Roland McGrath <roland@redhat.com>
* Makefile.am (DISTCHECK_CONFIGURE_FLAGS): New variable. tests/ 2005-11-18 Roland McGrath <roland@redhat.com> * test-subr.sh (installed_testrun): Treat /usr/lib64 like /usr/lib. * test-wrapper.sh: Likewise.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e7e93cdf..0c4d92b9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,6 +25,13 @@ SUBDIRS = $(mini_SUBDIRS) $(all_SUBDIRS)
EXTRA_DIST = elfutils.spec GPG-KEY NOTES COPYING.GPL
+# Make sure the test install uses lib64 when $LIB will yield lib64.
+# Make sure the test build uses the same compiler, which on e.g. ppc64
+# determines which platform we are actually testing.
+DISTCHECK_CONFIGURE_FLAGS = \
+ --libdir=`echo $(libdir) | sed "s,^$(exec_prefix),$$dc_install_base,"`\
+ CC="$(CC)"
+
distcheck-hook:
chmod -R u+w $(distdir)