summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorUlrich Drepper <drepper@redhat.com>2005-07-26 05:00:05 +0000
committerUlrich Drepper <drepper@redhat.com>2005-07-26 05:00:05 +0000
commitb08d5a8fb42f4586d756068065186b5af7e48dad (patch)
tree9f05f86be7877ed461b4dc05f53b29ea4fc0d2a1 /Makefile.am
Adjust for monotone.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..7d27a7c4
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,36 @@
+## Process this file with automake to create Makefile.in
+## Configure input file for elfutils.
+##
+## Copyright (C) 1996-2002, 2003, 2004, 2005 Red Hat, Inc.
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation, version 2.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software Foundation,
+## Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+##
+ACLOCAL_AMFLAGS = -I m4
+
+mini_SUBDIRS = config m4 lib libelf libelf-po
+# Add doc back when we have some real content.
+all_SUBDIRS = libebl libdw libdwfl libcpu libasm src po tests
+SUBDIRS = $(mini_SUBDIRS) $(all_SUBDIRS)
+
+EXTRA_DIST = elfutils.spec GPG-KEY NOTES COPYING.GPL
+
+distcheck-hook:
+ chmod -R u+w $(distdir)
+
+rpm: dist
+ rpmbuild -ts --sign elfutils-@PACKAGE_VERSION@.tar.gz
+
+# Tell version 3.79 and up of GNU make to not build goals in this
+# directory in parallel.
+.NOTPARALLEL: