summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2017-04-19 12:06:56 +0200
committerUlf Hermann <ulf.hermann@qt.io>2017-05-08 10:11:55 +0000
commit709d36789f4465b4e7a4948b98e0d7c5c66fac2f (patch)
tree18abf54b27adfd370e41c82067a3520dbf2ab82a /configure.ac
parent90fc7851b5f1f5dac88d5b822c12b1f4764e3d86 (diff)
Provide build rules for a compatibility library
We need to export open(), close(), malloc(), and free() from the C library we are using so that we can handle resources passed to and from elfutils correctly. For example, on Windows, calling free() on memory malloc()'d with a different C library will not work. In addition, having __cxa_demangle from the GNU libstdc++ available is very helpful, so we include that, too. Change-Id: I8e47e8f313fb3ffcc18309dadabf24acf36465f0 Reviewed-by: Christian Kandeler <christian.kandeler@qt.io>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5fa20c0b..c0efdfc8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -95,6 +95,7 @@ AM_CONDITIONAL(NATIVE_MACHO, test "$LIBEXT" = ".dylib")
eu_LIBNAME(elf,1)
eu_LIBNAME(dw,1)
eu_LIBNAME(asm,1)
+eu_LIBNAME(eu_compat,1)
AC_ARG_ENABLE(deterministic-archives,
[AS_HELP_STRING([--enable-deterministic-archives],