summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2017-04-11 18:36:08 +0200
committerUlf Hermann <ulf.hermann@qt.io>2017-05-02 16:11:20 +0000
commit8508151634702f1e52f36cbfce085955f074e60c (patch)
tree8372793633ff6c4edc9f65f03683fa6b11ef979c /configure.ac
parent1857705643ec74e01c7c03d6f04614dd796c6c2c (diff)
Make failure to find valgrind non-fatal
Change-Id: Iff66d48c764dbab2c3c7e63072cf4aff41b6fbe9 Reviewed-by: Christian Kandeler <christian.kandeler@qt.io>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1e7778df..a854013c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -389,7 +389,8 @@ AS_HELP_STRING([--enable-valgrind],[run all tests under valgrind]),
if test "$use_valgrind" = yes; then
AC_CHECK_PROG(HAVE_VALGRIND, valgrind, yes, no)
if test "$HAVE_VALGRIND" = "no"; then
- AC_MSG_ERROR([valgrind not found])
+ AC_MSG_WARN([valgrind not found])
+ use_valgrind=no
fi
fi
AM_CONDITIONAL(USE_VALGRIND, test "$use_valgrind" = yes)