summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2017-03-03 14:06:27 +0100
committerUlf Hermann <ulf.hermann@qt.io>2017-05-02 09:39:10 +0000
commit03a0d9e4e4eaacebbe4abfcb5b196b56b168a3fd (patch)
treeba0413e65ff2344d179158f0871f417e56c4db6f /configure.ac
parent2136e330bef96512d45b8a85b245b9ea95cf5106 (diff)
Check native binary format
If our native binary format is not ELF, there is no point in doing the textrel check and we have to exclude some tests that compile source code with the native compiler and then check something on the resulting binary with elfutils. Change-Id: Ib9c6b63481b40fa07dd741c1bb9dcb5d5a2ac6d1 Reviewed-by: Christian Kandeler <christian.kandeler@qt.io>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b2e03bb5..18ef6d6b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,6 +88,9 @@ AC_SUBST([LIBPREFIX])
AC_DEFINE_UNQUOTED(LIBPREFIX, "$LIBPREFIX")
AH_TEMPLATE([LIBPREFIX], [Host system file name prefix for dynamic libraries.])
AM_CONDITIONAL(POSTFIX_LIB_VERSION, test "$eu_postfix_lib_version" = "yes")
+AM_CONDITIONAL(NATIVE_ELF, test "$LIBEXT" = ".so")
+AM_CONDITIONAL(NATIVE_PE, test "$LIBEXT" = ".dll")
+AM_CONDITIONAL(NATIVE_MACHO, test "$LIBEXT" = ".dylib")
eu_LIBNAME(elf,1)
eu_LIBNAME(dw,1)