summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2017-04-04 13:10:09 +0200
committerUlf Hermann <ulf.hermann@qt.io>2017-05-08 09:35:50 +0000
commit416741d54a7dbebbd7a8dce75254f27d3a5ccd11 (patch)
tree2125160497661cd011b2c35e09074546a12ea332 /configure.ac
parent264c5144a282af15875435a93c6574efc006b5ac (diff)
Skip deleted test if fork(2) is unavailable
Change-Id: Ib52e92c34c5bd387b1e6310bb42d9102a639f262 Reviewed-by: Christian Kandeler <christian.kandeler@qt.io>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6cbd70d4..5fa20c0b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -608,6 +608,7 @@ AM_CONDITIONAL(HAVE_FEATURES_H, [test "x$ac_cv_header_features_h" = "xyes"])
AC_CHECK_HEADERS(stdio_ext.h)
AM_CONDITIONAL(HAVE_STDIO_EXT_H, [test "x$ac_cv_header_stdio_ext_h" = "xyes"])
+AC_CHECK_DECLS([fork], [], [], [[#include <unistd.h>]])
AC_CHECK_DECLS([feof_unlocked, ferror_unlocked, fputc_unlocked, fputs_unlocked,
fwrite_unlocked, putc_unlocked, putchar_unlocked],
[], [], [[#include <stdio.h>]])