summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2017-03-08 10:54:51 +0100
committerUlf Hermann <ulf.hermann@qt.io>2017-05-02 13:44:35 +0000
commitdbb67af24f5c16681b299d288cf9aa4e4dd9bd25 (patch)
tree9eaa8981996cf53dfc55b5c642201b332de77339 /configure.ac
parent46a61aa553eb304f399ac2f62c96ad2adbeda3c0 (diff)
Add a "selfcontained" mode to provide missing headers on windows
On windows there is no features.h, uid_t, gid_t, mode_t, and pid_t are not defined and there is also no elf.h. To make it possible to build other software against libelf and libdw, install our own version of elf.h, and a bare-bones features.h that provides exactly the above declarations. Change-Id: I9df3c8cbffe431b8b6834dbd2246e38df4f5e172 Reviewed-by: Christian Kandeler <christian.kandeler@qt.io>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e4b2946d..1e7778df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -124,6 +124,12 @@ AS_HELP_STRING([--enable-gnulib],
use_gnulib=$enableval, use_gnulib=no)
AM_CONDITIONAL(USE_GNULIB, test "$use_gnulib" = yes)
+AC_ARG_ENABLE([selfcontained],
+AS_HELP_STRING([--enable-selfcontained],
+ [install extra headers to enable including and linking the libraries on non-GNU systems]),
+ selfcontained=$enableval, selfcontained=no)
+AM_CONDITIONAL(SELFCONTAINED, test "$selfcontained" = yes)
+
AC_PROG_CC
gl_EARLY