summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Wielaard <mjw@redhat.com>2015-05-31 23:03:30 +0200
committerMark Wielaard <mjw@redhat.com>2015-06-05 14:52:29 +0200
commitf17a9bbc2963854090b81fdf58e49dc8dc6ccfba (patch)
treef8c0f99bbe916234f50773030d559fd095b3e542 /configure.ac
parent170f1bb0a8f49cd6c5e7b34aaa505928764866bb (diff)
Define MODVERSION in a more reproducable way.
We define MODVERSION to make sure the libebl backend modules match the elfutils build when we dlopen them. Using hostname and date makes it very hard to create reproducable builds. Define them a little more reproducable using LIBEBL_SUBDIR, eu_version and ac_cv_build. Signed-off-by: Mark Wielaard <mjw@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 58366d54..f9fb5be7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,12 +29,6 @@ dnl We use GNU make extensions; automake 1.10 defaults to -Wportability.
AM_INIT_AUTOMAKE([gnits 1.11 -Wno-portability dist-bzip2 no-dist-gzip parallel-tests])
AM_MAINTAINER_MODE
-dnl Unique ID for this build.
-MODVERSION="Build on $(hostname) $(date +%FT%R:%S%z)"
-AC_SUBST([MODVERSION])
-AC_DEFINE_UNQUOTED(MODVERSION, "$MODVERSION")
-AH_TEMPLATE([MODVERSION], [Identifier for modules in the build.])
-
AC_CONFIG_SRCDIR([libelf/libelf.h])
AC_CONFIG_FILES([Makefile])
AC_CONFIG_HEADERS([config.h])
@@ -388,6 +382,12 @@ esac
# Round up to the next release API (x.y) version.
eu_version=$(( (eu_version + 999) / 1000 ))
+dnl Unique ID for this build.
+MODVERSION="Build for ${LIBEBL_SUBDIR} ${eu_version} ${ac_cv_build}"
+AC_SUBST([MODVERSION])
+AC_DEFINE_UNQUOTED(MODVERSION, "$MODVERSION")
+AH_TEMPLATE([MODVERSION], [Identifier for modules in the build.])
+
AC_CHECK_SIZEOF(long)
# On aarch64 before glibc 2.20 we would get the kernel user_pt_regs instead