summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Wielaard <mark@klomp.org>2019-11-26 08:56:44 +0100
committerMark Wielaard <mark@klomp.org>2019-11-26 08:56:44 +0100
commit3f81dbd235172709021cc453d256e855d271686e (patch)
tree5dcd976da471b1f955be2e3f89ab361fe5927073 /configure.ac
parentedf79a4bbc80b35f40abce73986dc6d6e10d40bc (diff)
Fix BUILD_STATIC build and enable gcov for debuginfod.
libdw now always needs -lpthread and -ld even when BUILD_STATIC. BUILD_STATIC is only used when doing a gcov enabled build. Enable gcov coverage also for debuginfod. Signed-off-by: Mark Wielaard <mark@klomp.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5deec336..dc553bb6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -299,6 +299,7 @@ AC_ARG_ENABLE([gcov],
AS_HELP_STRING([--enable-gcov],[build binaries with gcov support]), [use_gcov=$enableval], [use_gcov=no])
if test "$use_gcov" = yes; then
CFLAGS="$CFLAGS -fprofile-arcs -ftest-coverage"
+ CXXFLAGS="$CXXFLAGS -fprofile-arcs -ftest-coverage"
LDFLAGS="$LDFLAGS -fprofile-arcs"
fi
AM_CONDITIONAL(GCOV, test "$use_gcov" = yes)