summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-07-04 12:11:07 +0100
committerMark Wielaard <mark@klomp.org>2018-07-05 20:09:30 +0200
commitd612684109f0395b86e4aaad9ba94e02f79a099a (patch)
tree456997bae6004859dd1d94acc561db4183035b89 /configure.ac
parent45591ea8e54c4af4ae9a00ed85f22e09133e3dcf (diff)
Require gawk in maintainer mode
gawk is required to build known_dwarf.h, so check for it in configure.ac. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1cf6245b..a3b29939 100644
--- a/configure.ac
+++ b/configure.ac
@@ -618,6 +618,10 @@ if test "x$enable_maintainer_mode" = xyes; then
if test "$HAVE_BISON" = "no"; then
AC_MSG_ERROR([bison needed in maintainer mode])
fi
+ AC_CHECK_PROG(HAVE_GAWK, gawk, yes, no)
+ if test "$HAVE_GAWK" = "no"; then
+ AC_MSG_ERROR([gawk needed in maintainer mode])
+ fi
else
if test ! -f ${srcdir}/libdw/known-dwarf.h; then
AC_MSG_ERROR([No libdw/known-dwarf.h. configure --enable-maintainer-mode])