summaryrefslogtreecommitdiffstats
path: root/libasm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libasm/Makefile.am')
-rw-r--r--libasm/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/libasm/Makefile.am b/libasm/Makefile.am
index bd5779e8..2b39eaef 100644
--- a/libasm/Makefile.am
+++ b/libasm/Makefile.am
@@ -65,12 +65,17 @@ if !MUDFLAP
libasm_pic_a_SOURCES =
am_libasm_pic_a_OBJECTS = $(libasm_a_SOURCES:.c=.os)
+libasm_so_LDLIBS =
+if USE_TLS
+libasm_so_LDLIBS += -lpthread
+endif
+
libasm_so_SOURCES =
libasm.so: libasm_pic.a libasm.map
$(LINK) -shared -o $@ -Wl,--whole-archive,$<,--no-whole-archive \
-Wl,--version-script,$(srcdir)/libasm.map,--no-undefined \
-Wl,--soname,$@.$(VERSION) \
- ../libebl/libebl.a ../libelf/libelf.so
+ ../libebl/libebl.a ../libelf/libelf.so $(libasm_so_LDLIBS)
if readelf -d $@ | fgrep -q TEXTREL; then exit 1; fi
ln -fs $@ $@.$(VERSION)