summaryrefslogtreecommitdiffstats
path: root/libelf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libelf/Makefile.am')
-rw-r--r--libelf/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/libelf/Makefile.am b/libelf/Makefile.am
index ddaeaa2b..ba4e3ebf 100644
--- a/libelf/Makefile.am
+++ b/libelf/Makefile.am
@@ -41,6 +41,7 @@ include_HEADERS = libelf.h gelf.h nlist.h
pkginclude_HEADERS = elf-knowledge.h
+libelf_a_CFLAGS = -fPIC -fvisibility=hidden $(AM_CFLAGS)
libelf_a_SOURCES = elf_version.c elf_hash.c elf_error.c elf_fill.c \
elf_begin.c elf_next.c elf_rand.c elf_end.c elf_kind.c \
gelf_getclass.c elf_getbase.c elf_getident.c \