summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMilian Wolff <milian.wolff@kdab.com>2022-12-03 15:56:48 +0100
committerMilian Wolff <milian.wolff@kdab.com>2022-12-08 19:42:05 +0000
commit813e5fa8cad97eb1af227bf8bdcd60d7cd8bffa1 (patch)
tree92dea66959eaa3f4e345cce924ba3cd390d11721 /CMakeLists.txt
parenta4b06facbdeb370c4fcf721eca266fca19e4fe59 (diff)
Fix compile with -DQT_NO_CAST_FROM_ASCII -DQT_NO_CAST_TO_ASCII
Change-Id: If53db019f7855128fa705b1f9bc344b4d78dcdc8 Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c7f3ad6..73b1e71 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,6 @@ include(CheckSymbolExists)
set(CMAKE_REQUIRED_LIBRARIES elfutils::dw elfutils::elf)
check_symbol_exists(dwfl_get_debuginfod_client "libdwfl.h" HAVE_DWFL_GET_DEBUGINFOD_CLIENT)
-add_definitions(-DQT_USE_QSTRINGBUILDER)
+add_definitions(-DQT_NO_CAST_FROM_ASCII -DQT_NO_CAST_TO_ASCII -DQT_USE_QSTRINGBUILDER)
add_subdirectory(app)
add_subdirectory(tests)