aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Adam <cristian.adam@qt.io>2019-07-13 11:57:35 +0200
committerCristian Adam <cristian.adam@qt.io>2019-08-14 13:40:48 +0000
commitab9aae4856872978f7a492f1991077ab87e9b7bd (patch)
treed0177f7560a989d378278fb0f8ba64ae4cbf3dc9 /CMakeLists.txt
parent7a39a3c9df9987b66fb6cf2720c23538ee3a471f (diff)
CMake build: Build with PCH
This commit enables building with upstream CMake PCH support. Change-Id: Ib37745b00e7560e804483e7c2c2a3fa7cf6d663c Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 43d7d9bce6..41278e8d93 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,6 +20,7 @@ set(CMAKE_CXX_EXTENSIONS OFF)
option(WITH_TESTS "Build Tests" OFF)
option(WITH_DEBUG_CMAKE "Enabled CMake project debugging functionality (e.g. source file disk checking)" OFF)
+option(BUILD_WITH_PCH "Build with precompiled headers" ON)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
@@ -35,7 +36,7 @@ endif()
find_package(Qt5
COMPONENTS Concurrent Core Network PrintSupport Qml Quick QuickWidgets
- Sql ${_TEST_QT_COMPONENT}
+ Sql Widgets ${_TEST_QT_COMPONENT}
REQUIRED
)