aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Hartmann <thomas.hartmann@qt.io>2022-12-07 16:15:20 +0100
committerThomas Hartmann <thomas.hartmann@qt.io>2022-12-08 12:33:36 +0100
commiteee8773406e27c1fb46aafb1f77415d4b033c856 (patch)
tree3e72dc33080ab3dade543c1c8bc39b85c2188f7b /CMakeLists.txt
parent8689a46d63f195312305d6b7e48fa0d6729a0b7c (diff)
Make plugins staticqds-4.0qds-3.9
Remove the project Change-Id: I25bc4e96be6f54f30f87fdab8244f240f0a53646 Reviewed-by: Thomas Hartmann <thomas.hartmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 12 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0f03162..88ff15c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,15 +1,20 @@
cmake_minimum_required(VERSION 3.16)
##PROJECT_VERSION_MAJOR = 6
-project(QtQuickDesignerComponents
- DESCRIPTION "QtQuick Designer Components"
- HOMEPAGE_URL "https://qt.io/"
- VERSION "6.4.0"
- LANGUAGES CXX C
-)
+
+## project(QtQuickDesignerComponents
+## DESCRIPTION "QtQuick Designer Components"
+## HOMEPAGE_URL "https://qt.io/"
+## VERSION "6.4.0"
+## LANGUAGES CXX C
+##)
include(CMakePrintHelpers)
+set(PROJECT_VERSION_MAJOR 6)
+set(PROJECT_VERSION_MINOR 4)
+set(PROJECT_VERSION 6.4.1)
+
cmake_print_variables(PROJECT_SOURCE_DIR)
cmake_print_variables(PROJECT_VERSION_MAJOR)
message("$(PROJECT_SOURCE_DIR)")
@@ -28,6 +33,6 @@ find_package(Qt6
Gui
)
-qt_standard_project_setup()
+### qt_standard_project_setup()
add_subdirectory(src)