aboutsummaryrefslogtreecommitdiffstats
path: root/Templates/gui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Templates/gui/CMakeLists.txt')
-rw-r--r--Templates/gui/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/Templates/gui/CMakeLists.txt b/Templates/gui/CMakeLists.txt
index 69c40988..3abed828 100644
--- a/Templates/gui/CMakeLists.txt
+++ b/Templates/gui/CMakeLists.txt
@@ -1,5 +1,5 @@
cmake_minimum_required(VERSION 3.16)
-project($safeprojectname$ LANGUAGES CXX)
+project($projectname$ LANGUAGES CXX)
set(CMAKE_INCLUDE_CURRENT_DIR ON)
@@ -26,21 +26,21 @@ set(PROJECT_SOURCES
)
if(Qt6)
- qt_add_executable($safeprojectname$ MANUAL_FINALIZATION ${PROJECT_SOURCES})
+ qt_add_executable($projectname$ MANUAL_FINALIZATION ${PROJECT_SOURCES})
else()
- add_executable($safeprojectname$ ${PROJECT_SOURCES})
+ add_executable($projectname$ ${PROJECT_SOURCES})
endif()
-set_target_properties($safeprojectname$
+set_target_properties($safeprojectnname$
PROPERTIES
WIN32_EXECUTABLE TRUE
)
-target_link_libraries($safeprojectname$
+target_link_libraries($projectname$
PUBLIC
${QT_LIBS}
)
if(Qt6)
- qt_finalize_executable($safeprojectname$)
+ qt_finalize_executable($projectname$)
endif()