summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Krus <mike.krus@kdab.com>2021-07-10 23:40:45 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-07-19 17:09:15 +0000
commit61058758ab8621c67e62902244bea9253d0517b4 (patch)
tree59e0cbe985877e8a355341b28e67456c61a7d17f /CMakeLists.txt
parent8d82331da9ccbca9e3cc4b7d8a952d855b1e525d (diff)
Disable RHI Renderer by default
RHI renderer use ShaderTools which is GPL licensed. This patch disables the plugin by default until Qt3D provides a suitable replacement for the dependency. To enable the RHI backend, compile Qt3D and pass parameter -DFEATURE_qt3d_rhi_renderer=ON to cmake. Unfortunate side effect of RHI backend being disabled is that when using Scene3D, the QtQuick renderer must be configured to use the opengl backend. [ChangeLog] RHI Backend is not longer built by default Task-number: QTBUG-94960 Change-Id: I0bff7523e159b800734b58bfef37e5088d0a0d41 Reviewed-by: Paul Lemire <paul.lemire@kdab.com> (cherry picked from commit 3964b273459c2999f33d51b96afe6fb68f07d52f) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e027a2b36..1e125b855 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,7 +19,7 @@ set(QT_USE_FIXED_QT_ADD_RESOURCE_BASE TRUE)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
- Concurrent Widgets Qml Quick Gamepad OpenGL ShaderTools Multimedia)
+ Concurrent Widgets Qml Quick Gamepad OpenGL Multimedia)
# special case end
if(NOT TARGET Qt::Gui)