summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2023-04-12 15:04:14 +0200
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2023-05-31 13:24:27 +0000
commit6ad1ad9953c2a13a147ff6cd033944ed8fa6d2f6 (patch)
treee6f33a0e80bacb75b67f7a0043a1c20b1abe8b92 /CMakeLists.txt
parentb41776d47903ff178df60830b0216fde1722ee71 (diff)
Add the use of the qt_internal_project_setup function
The function sets the required CMake variables and policies. Task-number: QTBUG-112685 Change-Id: I84d24c8ac2bc0979152554142d80b3eb53f30856 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io> (cherry picked from commit aab1bc000f67602603810750843695a4005f599c) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fbd6bb51d..0ab52d30f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,8 @@ find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
Network Concurrent Widgets Qml Quick ShaderTools Gamepad OpenGL Multimedia QuickWidgets)
# special case end
+qt_internal_project_setup()
+
if(NOT TARGET Qt::Gui)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
return()