summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-06-11 14:45:11 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-06-15 10:36:16 +0200
commit034de43294ff758d65f8eed342f1c41f4cf49cae (patch)
treef70fbf3c41673a217b82f22b90197e7bd1c503cb /CMakeLists.txt
parentd79376732105dea749e71cdb114251084c7138a9 (diff)
Remove unneeded CMake variable assignments
Remove assignments to the transitionary variables QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS and QT_USE_FIXED_QT_ADD_RESOURCE_BASE. Both are not needed anymore. Task-number: QTBUG-94444 Change-Id: Ie54f38267a7529e96117e1be2b2bf2164372024f Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e027a2b36..69087ff96 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,12 +11,6 @@ project(Qt3D # special case
)
# special case begin
-# Make sure we only use latest private CMake API, aka no compatibility wrappers.
-set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
-
-# Make sure we use the fixed BASE argument of qt_add_resource.
-set(QT_USE_FIXED_QT_ADD_RESOURCE_BASE TRUE)
-
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
Concurrent Widgets Qml Quick Gamepad OpenGL ShaderTools Multimedia)