summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Krus <mike.krus@kdab.com>2021-07-10 23:40:45 +0100
committerMike Krus <mike.krus@kdab.com>2021-07-19 16:14:26 +0100
commit3964b273459c2999f33d51b96afe6fb68f07d52f (patch)
tree06b8b71bc2100e5093bd79321b43d6d4e541492a /CMakeLists.txt
parent7f1f3c358258331f86dc792c653482c82bbf2ec6 (diff)
Disable RHI Renderer by default
RHI renderer use ShaderTools which is GPL licensed. This patch disables the plugin by default until Qt3D provides a suitable replacement for the dependency. To enable the RHI backend, compile Qt3D and pass parameter -DFEATURE_qt3d_rhi_renderer=ON to cmake. Unfortunate side effect of RHI backend being disabled is that when using Scene3D, the QtQuick renderer must be configured to use the opengl backend. [ChangeLog] RHI Backend is not longer built by default Task-number: QTBUG-94960 Pick-to: 6.1 6.2 Change-Id: I0bff7523e159b800734b58bfef37e5088d0a0d41 Reviewed-by: Paul Lemire <paul.lemire@kdab.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 69087ff96..7714f9926 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,7 +13,7 @@ project(Qt3D # special case
# special case begin
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS
- Concurrent Widgets Qml Quick Gamepad OpenGL ShaderTools Multimedia)
+ Concurrent Widgets Qml Quick Gamepad OpenGL Multimedia)
# special case end
if(NOT TARGET Qt::Gui)